Inserted my seagate 7200 SATA with opensuse 10.3
got all I need working:
nvidia 8400M – binary nvidia driver all works, even three screens setup with built-in LCD/external VGA/HDMI LCD TV ( LCD brightness control is not working, nvidia driver problem )
intel 4965 wifi – iwl4965 works for b/g, have no N to test
Marvell 88E8036 – sky2 works good enough for a marvell adapter
audio – alsa 1.0.16 options snd-hda-intel enable=1 model=vaio position_fix=0 works with headphones and built-in microphone
webcam – ricohn r5u870 Detected Sony VGP-VCC8, tested with skype, works
blue ray burner – Optiarc BD ROM BC-5500A, burned a DVD-RW, installed openSUSE 11b3 from it on the lab rat HP laptop, works
bluetooth – broadcom crap with options hci_usb reset=1, works

the rest of the things works without any intervention or errors
not tested yet:
firewire, card reader

Overall impression:
A solid machine with nice magnesium case, a brilliant LCD, responsive and well “layouted” keyboard
Linux works great on it except for the never-go-away problems with custom ACPI stuff.

Comment if you stumble upon this post and have questions.

  • http://www.opensurf.it iappi

    Thank you very much!!
    I’d like to install Ubuntu 8.04 on sony vaio fz38M and so I can image that it will run.
    bye

  • http://www.gfdsa.org gfdsa

    figurati iappi, dovrebbe andare qualsiasi distributivo su questa macchina se e’ recente

  • Sanajrbek

    Hi.I have installed ubuntu on my sony vaio fz340e.And I cannot use my headphones.It gives sound to built in speakers even if headphone is plugged.

    Do you know how can I fix it?Thanks in advance.

  • http://www.gfdsa.org gfdsa

    Sanajrbek,
    audio – alsa 1.0.16 options snd-hda-intel enable=1 model=vaio position_fix=0 works with headphones and built-in microphone
    have no idea about gubuntus or whatever

Post Navigation